Back to overview
Degraded

Chrome Runtime Issues

Apr 8, 2026 at 7:20pm UTC
Affected services
Live Service
Automated Service
Record & Review Service
Virtual Testing Center

Resolved
Apr 8, 2026 at 11:04pm UTC

All services are operational. We will continue to monitor.

Updated
Apr 8, 2026 at 9:14pm UTC

No new reports of session termination have been received since the release. We are continuing to monitor.

Updated
Apr 8, 2026 at 8:14pm UTC

Our team has released a new SecureSession Extension to address an issue that is causing some students to end prematurely. We will continue monitoring to ensure this is fully resolved.

Created
Apr 8, 2026 at 7:20pm UTC

We are aware that some users on the latest version of Chrome are experiencing session terminations. Our team is actively investigating and will provide updates as they become available.